تمام سوالات سوالات بدون پاسخ سوال بپرسید

من در نصب پلاگین redmine_contact که از redminecrm.com دانلود کردم، به مشکل برخوردم. ردماینی که من استفاده میکنم: bitnami_redmine 2.2.3.0 است.

مشکل اینست که نسخه نصب شده یکی از کتابخانه‌ها، جدیدتر از نسخه‌ای است که این پلاگین نیاز دارد! خطای پلاگین در زمان نصب:

(in /home/toloo/redmine-2.2.3-0/apps/redmine/htdocs)
Could not find sprockets-2.2.1 in any of the sources
Run `bundle install` to install missing gems.

در صورتی که با دستور bundle show sprockets مشخص میشود که نسخه ۲.۲.۲ آن نصب است.

1 پاسخ

سلام دوست عزیز،

  1. در کل پیغامی که من میبینم این رو میگه که باید یه Gem رو نصب کنی. برو به شاخه اصلی برنامه Redmine ( منظورم همون جایی که فایلهای Gemfile و شاخه public و bin و vendor و config و غیره هست) و دستور زیر رو بزن:

    bundle install

با این کار هر چیزی که لازم داره نصب میکنه. بعد اگه از Apache بعنوان وب سرور استفاده می‌کنی، اون رو restart کن.

  1. این رو هم بگم که معمولا نسخه جدیدتر اگه نصب باشه مشکلی نیست. در هر صورت اگه مشکلت حل نشد، میتونی هرچی فایل Gemlock پیدا کردی، پاک کنی (نگران نباش چون دوباره ساخته میشه) و مجددا شماره ۱ رو اجرا کنی.
  2. در مواردی خیلی اندک پیش میاد که برنامه نویس، نسخه یک Gem رو یک چیز خاص در نظر گرفته و دقیقا شماره اون رو ذکر کرده. توی فایل Gemfile میتونی Gem مورد نظرت رو پیدا کنی و شماره نسخه مربوطه رو اصلاح کنی.

    یا حق
toggle preview



آموزش زبان برنامه نویسی C#
آموزش jquery
آموزش برنامه نویسی
آموزش طراحی وبسایت
آموزش مدیریت وبسایت
آموزش جاوا Java
آموزش پایتون Python
آموزش سی شارپ C#‎
آموزش HTML و CSS
آموزش JavaScript جاوااسکریپت
آموزش jQuery جی کوئری
آموزش ساخت ربات تلگرام
آموزش برنامه‌نویسی PHP
آموزش برنامه‌نویسی اندروید
● آموزش‌های رایگان

سوالات مرتبط

راهنمای استفاده از ویرایشگر
  • *ایتالیک*‌ یا __ایتالیک__
  • **ضخیم** یا __ضخیم__
  • آدرس:[متن](http://url.com/ "عنوان")
  • عکس?![alt متن](/path/img.jpg "عنوان")
  • لیست عددی: 1. Foo 2. Bar
  • برای رفتن به خط بعد، هر جا مایلید که خط جدید شروع شود دو کاراکتر فاصله (space) قرار دهید
  • تگ‌های ساده HTML هم پشتیبانی می‌شوند

تگها:
این سوال را دنبال کنیدتوسط ایمیل: ایمیل شما (باید معتبر باشد, هرگز به دیگران نمایش داده نمیشود):

هنگامی که شما به سیستم وارد شوید،قادر خواهید بود برای بروز رسانی ها مشترک شوید.


توسط RSS:

پاسخها

پاسخها و نظرها